mpg123: replace $(shell ...) call with $(subst ...)
authorArnout Vandecappelle <arnout@mind.be>
Sun, 12 Jul 2015 14:35:29 +0000 (16:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 22:42:01 +0000 (00:42 +0200)
There's no reason to use a shell here.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpg123/mpg123.mk

index 4c534e2b1a982cd3a8d03082ce5067127172b13f..171cbde0be0eab1b035ce4a550192ef0507a2d0c 100644 (file)
@@ -69,7 +69,7 @@ MPG123_CONF_OPTS += --with-default-audio=alsa
 MPG123_DEPENDENCIES += alsa-lib
 endif
 
-MPG123_CONF_OPTS += --with-audio=$(shell echo $(MPG123_AUDIO) | tr ' ' ,)
+MPG123_CONF_OPTS += --with-audio=$(subst $(space),$(comma),$(MPG123_AUDIO))
 
 ifeq ($(BR2_PACKAGE_LIBTOOL),y)
 MPG123_DEPENDENCIES += libtool