package/yaml-cpp: disable testing and parse tools
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 30 Jul 2015 18:39:46 +0000 (20:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Jul 2015 21:08:23 +0000 (23:08 +0200)
The gmock testing framework uses fork() and therefor yaml-cpp fails to build
for a MMU-less targets. Since we are only interested in building the yaml-cpp
library we disable the testing and parse tools (command line tools).

Fixes:
http://autobuild.buildroot.net/results/2ce/2ce3c6d0140696cdf73f2ad1499b779c83ad8f6e/

Cc: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/yaml-cpp/yaml-cpp.mk

index cea54a94694e0503e7e6231f5322ea47f56dda90..6a01b02a3be1bc685036be6cf385f47a375ab265 100644 (file)
@@ -12,4 +12,7 @@ YAML_CPP_LICENSE_FILES = license.txt
 
 YAML_CPP_DEPENDENCIES = boost
 
+# Disable testing and parse tools
+YAML_CPP_CONF_OPTS += -DYAML_CPP_BUILD_TOOLS=OFF
+
 $(eval $(cmake-package))