zsh: new package
authorPhil Eichinger <phil.eichinger@gmail.com>
Tue, 1 Oct 2013 09:59:31 +0000 (11:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Oct 2013 20:43:39 +0000 (22:43 +0200)
Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/zsh/Config.in [new file with mode: 0644]
package/zsh/zsh.mk [new file with mode: 0644]

index 0ea814a54c5db8f0605ac8c7ffaa35f54de2ae13..363113f8a35d7b970cdc4fcc9834003b0ffa2ed6 100644 (file)
@@ -923,6 +923,7 @@ source "package/at/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/bash/Config.in"
 source "package/dash/Config.in"
+source "package/zsh/Config.in"
 endif
 source "package/dialog/Config.in"
 source "package/dtach/Config.in"
diff --git a/package/zsh/Config.in b/package/zsh/Config.in
new file mode 100644 (file)
index 0000000..fd63aa9
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_ZSH
+       bool "zsh"
+       select BR2_PACKAGE_NCURSES
+       help
+         zsh is a shell designed for interactive use, although it is also
+         a powerful scripting language. Many of the useful features of bash,
+         ksh, and tcsh were incorporated into zsh; many original features
+         were added.
+
+         http://zsh.sourceforge.net/
diff --git a/package/zsh/zsh.mk b/package/zsh/zsh.mk
new file mode 100644 (file)
index 0000000..ca865a4
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# zsh
+#
+################################################################################
+
+ZSH_VERSION=5.0.2
+ZSH_SITE=http://downloads.sourceforge.net/project/zsh/zsh/$(ZSH_VERSION)
+ZSH_LICENSE = MIT-like
+ZSH_LICENSE_FILES = LICENCE
+
+ZSH_DEPENDENCIES = ncurses
+
+$(eval $(autotools-package))