package/kf5: base infrastructure
authorPierre Ducroquet <pinaraf@pinaraf.info>
Thu, 15 Feb 2018 20:48:11 +0000 (21:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 30 Jun 2018 22:04:14 +0000 (00:04 +0200)
KDE Frameworks 5 is a set of libraries built on the Qt framework
providing a lot of powerfull classes and solutions for developers
building Qt applications.

Unlike the previous KDE libraries, they are split in tiny packages,
reducing dependencies as much as possible, making them usable even for
embedded projects.

This first commit introduce the kf5 packages folder.

Signed-off-by: Pierre Ducroquet <pinaraf@pinaraf.info>
[Thomas:
 - Needs Qt >= 5.8, so added a dependency on
   BR2_PACKAGE_QT5_VERSION_LATEST
 - Update to version 5.47.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/kf5/Config.in [new file with mode: 0644]
package/kf5/kf5.mk [new file with mode: 0644]

index 0a9decbb55e0cbb687156d92ea607c348650eb4c..b1307e2bbf2d644dc1c1bfa086c85ea15c60f901 100644 (file)
@@ -2141,3 +2141,6 @@ F:        package/qjson/
 F:     package/quazip/
 F:     package/shapelib/
 F:     package/tinc/
+
+N:     Pierre Ducroquet <pinaraf@pinaraf.info>
+F:     package/kf5/
index f72670c4e58a1442043f12407daf512c68463995..e94a6a8c12c4e0a652ed3cee17bda19b8ff89fe0 100644 (file)
@@ -310,6 +310,7 @@ comment "Graphic libraries"
 comment "Other GUIs"
        source "package/qt/Config.in"
        source "package/qt5/Config.in"
+       source "package/kf5/Config.in"
 if BR2_PACKAGE_QT || BR2_PACKAGE_QT5
 comment "QT libraries and helper libraries"
        source "package/grantlee/Config.in"
diff --git a/package/kf5/Config.in b/package/kf5/Config.in
new file mode 100644 (file)
index 0000000..cbc3d0b
--- /dev/null
@@ -0,0 +1,10 @@
+menuconfig BR2_PACKAGE_KF5
+       bool "KF5"
+       depends on BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5_VERSION_LATEST
+       help
+         This option enables the KF5 KDE Frameworks. Sub-options
+         allow to select which modules should be built.
+
+if BR2_PACKAGE_KF5
+endif
diff --git a/package/kf5/kf5.mk b/package/kf5/kf5.mk
new file mode 100644 (file)
index 0000000..8360fc9
--- /dev/null
@@ -0,0 +1,11 @@
+################################################################################
+#
+# kf5
+#
+################################################################################
+
+KF5_VERSION_MAJOR = 5.47
+KF5_VERSION = $(KF5_VERSION_MAJOR).0
+KF5_SITE = https://download.kde.org/stable/frameworks/$(KF5_VERSION_MAJOR)
+
+include $(sort $(wildcard package/kf5/*/*.mk))