package/hostapd: ignore CVE-2021-30004 when using openssl
authorMatt Weber <matthew.weber@rockwellcollins.com>
Wed, 21 Apr 2021 20:42:31 +0000 (15:42 -0500)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 24 Apr 2021 09:28:02 +0000 (11:28 +0200)
The CVE can be ignored when the internal TLS impl isn't used.

https://security-tracker.debian.org/tracker/CVE-2021-30004
 "Issue only affects the "internal" TLS implementation
 (CONFIG_TLS=internal)"

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/hostapd/hostapd.mk

index efeefd8b353e91f7dede3796e17b23b405873d44..2995545d18356806196ca3be6a4eb5837c05183f 100644 (file)
@@ -38,6 +38,8 @@ ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
 HOSTAPD_DEPENDENCIES += host-pkgconf libopenssl
 HOSTAPD_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=openssl\)/\1/'
+# Issue only affects the "internal" TLS implementation
+HOSTAPD_IGNORE_CVES += CVE-2021-30004
 else
 HOSTAPD_CONFIG_DISABLE += CONFIG_EAP_PWD CONFIG_EAP_TEAP
 HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=\).*/\1internal/'