package/cog: new package
authorFrancois Perrad <fperrad@gmail.com>
Tue, 5 Feb 2019 20:41:52 +0000 (21:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 11 Feb 2019 21:26:48 +0000 (22:26 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cog/Config.in [new file with mode: 0644]
package/cog/cog.hash [new file with mode: 0644]
package/cog/cog.mk [new file with mode: 0644]

index 9746ba6792d2a497978485810f1a574ad1ea21f5..45b59de27697e17bbfd32c429ac5a69e65e5ab02 100644 (file)
@@ -67,6 +67,7 @@ F:    package/sngrep/
 
 N:     Adrian Perez de Castro <aperez@igalia.com>
 F:     package/brotli/
+F:     package/cog/
 F:     package/libepoxy/
 F:     package/libwpe/
 F:     package/webkitgtk/
@@ -824,6 +825,7 @@ F:  configs/olimex_a20_olinuxino_*
 F:     package/4th/
 F:     package/botan/
 F:     package/chipmunk/
+F:     package/cog/
 F:     package/dado/
 F:     package/ficl/
 F:     package/gdbm/
index 0a5180a238328ad45503fb3e35487a3b65c0ff02..1b5d5c9d7f0ae1767184da1f9bdd6c82f8c12652 100644 (file)
@@ -263,6 +263,7 @@ endmenu
 menu "Graphic libraries and applications (graphic/text)"
 
 comment "Graphic applications"
+       source "package/cog/Config.in"
        source "package/fswebcam/Config.in"
        source "package/ghostscript/Config.in"
        source "package/glmark2/Config.in"
diff --git a/package/cog/Config.in b/package/cog/Config.in
new file mode 100644 (file)
index 0000000..768fcef
--- /dev/null
@@ -0,0 +1,27 @@
+comment "cog needs wpewebkit and a toolchain w/ threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_PACKAGE_WPEWEBKIT || !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_COG
+       bool "cog"
+       depends on BR2_PACKAGE_WPEWEBKIT
+       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus
+       depends on BR2_USE_MMU # dbus
+       select BR2_PACKAGE_DBUS
+       help
+         Single "window" launcher for the WebKit WPE port, and
+         helper library for implementing WPE launcher. It does
+         not provide any chrome, and is suitable to be used
+         as a Web application container.
+
+if BR2_PACKAGE_COG
+
+config BR2_PACKAGE_COG_PROGRAMS_HOME_URI
+       string "home uri"
+       default "https://wpewebkit.org"
+       help
+         Default URI to open when "cog" is launched. If an empty
+         string is used, there is no default and the URI to open
+         must be always specified in the command line.
+
+endif
diff --git a/package/cog/cog.hash b/package/cog/cog.hash
new file mode 100644 (file)
index 0000000..97daf72
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally generated
+sha256 a6abadb78395226bac2e1dd5467feab2cc8c493eab6894a09a51a8e072e38c06  cog-v0.2.0.tar.gz
+
+# Hashes for license files:
+sha256 e6c42d93c68b292bcccf6d2ec3e13da85df90b718ba27c2c2a01053a9d009252  COPYING
diff --git a/package/cog/cog.mk b/package/cog/cog.mk
new file mode 100644 (file)
index 0000000..43f1315
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# cog
+#
+################################################################################
+
+COG_VERSION = v0.2.0
+COG_SITE = $(call github,Igalia,cog,$(COG_VERSION))
+COG_DEPENDENCIES = dbus wpewebkit wpebackend-fdo
+COG_LICENSE = MIT
+COG_LICENSE_FILES = COPYING
+COG_CONF_OPTS = \
+       -DCOG_BUILD_PROGRAMS=ON \
+       -DCOG_PLATFORM_FDO=ON \
+       -DCOG_HOME_URI='$(call qstrip,$(BR2_PACKAGE_COG_PROGRAMS_HOME_URI))'
+
+$(eval $(cmake-package))