gst-plugins-good: add wavpack + gdkpixbuf options
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 13:15:02 +0000 (14:15 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Jan 2013 13:19:01 +0000 (14:19 +0100)
Based on patch by Bogdan Radulescu <bogdan_radulescu99@yahoo.com>

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index b5006e62391409d01950389d4b6ef8f08c7b9228..1498ed01078a0f93946963f49a6103526c4c1a18 100644 (file)
@@ -186,6 +186,10 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLAC
        bool "flac (libFLAC)"
        select BR2_PACKAGE_FLAC
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GDKPIXBUF
+       bool "gdkpixbuf"
+       select BR2_PACKAGE_GDK_PIXBUF
+
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
        bool "ossaudio (OSS audio)"
 
@@ -205,4 +209,8 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX
        bool "speex"
        select BR2_PACKAGE_SPEEX
 
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPACK
+       bool "wavpack (*.wv audio)"
+       select BR2_PACKAGE_WAVPACK
+
 endif
index f64527decea2719d3947ac9fa8f7b145ad00ca9f..2ba3e201037bb5a610fa08dded52288b81dbb67d 100644 (file)
@@ -342,6 +342,13 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GDKPIXBUF),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-gdk_pixbuf
+GST_PLUGINS_GOOD_DEPENDENCIES += gdk-pixbuf
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-gdk_pixbuf
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-oss
 else
@@ -375,4 +382,11 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-speex
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPACK),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-wavpack
+GST_PLUGINS_GOOD_DEPENDENCIES += wavpack
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-wavpack
+endif
+
 $(eval $(autotools-package))