libva: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 11 Dec 2018 18:19:43 +0000 (19:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:48:21 +0000 (21:48 +0100)
Set ac_cv_path_WAYLAND_SCANNER to the wayland-scanner in the host
directory otherwise build will fail because libva will use pkgconfig to
find it

Fixes:
 - http://autobuild.buildroot.org/results/836d3a7085c576f607b1532d5204a54d6c2c1e66

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libva/libva.mk

index 9a70bb83fd2be9d2d17b8426f18727ddb6c7a68c..b897d358495f0a6c6f516622f3a35a8ec79b6e46 100644 (file)
@@ -30,6 +30,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 LIBVA_DEPENDENCIES += wayland
+LIBVA_CONF_ENV += ac_cv_path_WAYLAND_SCANNER=$(HOST_DIR)/usr/bin/wayland-scanner
 LIBVA_CONF_OPTS += --enable-wayland
 else
 LIBVA_CONF_OPTS += --disable-wayland