opkg: fix configure step by adding host-pkgconf dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jan 2013 06:39:15 +0000 (06:39 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 15 Jan 2013 20:37:47 +0000 (21:37 +0100)
The opkg configure.ac uses the PKG_CHECK_MODULES() m4 macro, which is
provided by the .m4 files installed by host-pkgconf, so we must have
this package as a dependency.

Fixes:

  http://autobuild.buildroot.org/results/069fcab6e7dd5a1f07251ba6f52f65643a2f7594/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/opkg/opkg.mk

index 3ba61aea47c4ee01965a79c026e2993c2e7db288..9932d3f8bd17fcaf179c00718d9caeee7affea0e 100644 (file)
@@ -11,6 +11,8 @@ OPKG_SITE_METHOD = svn
 OPKG_INSTALL_STAGING = YES
 OPKG_CONF_OPT = --disable-curl --disable-gpg
 OPKG_AUTORECONF = YES
+# Uses PKG_CHECK_MODULES() in configure.ac
+OPKG_DEPENDENCIES = host-pkgconf
 
 # Ensure directory for lockfile exists
 define OPKG_CREATE_LOCKDIR