openpowerlink: bump to version 1.8.4
authorRomain Naour <romain.naour@openwide.fr>
Thu, 31 Oct 2013 17:20:26 +0000 (18:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 10 Nov 2013 23:57:47 +0000 (00:57 +0100)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openpowerlink/openpowerlink-0001-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch [new file with mode: 0644]
package/openpowerlink/openpowerlink-0001-fix-demo-mn-qt.patch [deleted file]
package/openpowerlink/openpowerlink-0002-Fix-compilation-issue-for-kernels-3.5.patch [deleted file]
package/openpowerlink/openpowerlink-0003-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch [deleted file]
package/openpowerlink/openpowerlink.mk

diff --git a/package/openpowerlink/openpowerlink-0001-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch b/package/openpowerlink/openpowerlink-0001-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch
new file mode 100644 (file)
index 0000000..bed878e
--- /dev/null
@@ -0,0 +1,28 @@
+From cb6c4ff053e72f7fe5954894aebe2c0d94120b2d Mon Sep 17 00:00:00 2001
+From: Romain Naour <romain.naour@openwide.fr>
+Date: Thu, 3 Oct 2013 23:22:17 +0200
+Subject: [PATCH 5/5] [FIX] Linux Powerlink user lib: add INSTALL
+
+Signed-off-by: Romain Naour <romain.naour@openwide.fr>
+---
+ Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
+index e67d573..40b7756 100644
+--- a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
++++ b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
+@@ -329,7 +329,9 @@ ENDIF ()
+ #
+ # Installation
+ #
+-IF (WIN32)
++IF (UNIX)
++    INSTALL(TARGETS powerlink ARCHIVE DESTINATION lib)
++ELSEIF (WIN32)
+     IF (CFG_X86_WINDOWS_DLL)
+         INSTALL(TARGETS openPOWERLINK RUNTIME DESTINATION bin)
+     ENDIF (CFG_X86_WINDOWS_DLL)
+--
+1.8.4
+
diff --git a/package/openpowerlink/openpowerlink-0001-fix-demo-mn-qt.patch b/package/openpowerlink/openpowerlink-0001-fix-demo-mn-qt.patch
deleted file mode 100644 (file)
index c573662..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-commit 8658075bd7c49a7481e8f6d0d7a13b0651e1dfd7
-Author: Romain Naour <romain.naour@openwide.fr>
-Date:   Wed Sep 18 23:33:04 2013 +0200
-
-    [FIX] demo_mn_qt: add EplDebug.c in demo_sources list
-
-    demo_mn_qt use EplGetEmergErrCodeStr()
-
-    Signed-off-by: Romain Naour <romain.naour@openwide.fr>
-
-diff --git a/Examples/X86/Generic/demo_mn_qt/CMakeLists.txt b/Examples/X86/Generic/demo_mn_qt/CMakeLists.txt
-index 9db2f7f..48ae9eb 100644
---- a/Examples/X86/Generic/demo_mn_qt/CMakeLists.txt
-+++ b/Examples/X86/Generic/demo_mn_qt/CMakeLists.txt
-@@ -78,6 +78,7 @@ SET(DEMO_SOURCES src/EplApi.cpp
-                  src/MainWindow.cpp
-                  src/NodeState.cpp
-                  ${POWERLINK_SOURCE_DIR}/ObjDicts/${OBJDICT}/EplApiProcessImageSetup.c
-+                 ${POWERLINK_SOURCE_DIR}/EplStack/EplDebug.c
-     )
-
- # The TRACE macros need trace.c on the Windows platform
diff --git a/package/openpowerlink/openpowerlink-0002-Fix-compilation-issue-for-kernels-3.5.patch b/package/openpowerlink/openpowerlink-0002-Fix-compilation-issue-for-kernels-3.5.patch
deleted file mode 100644 (file)
index 064a6f0..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From 9990e19bc554d11c4123986692c5e0572682467a Mon Sep 17 00:00:00 2001
-From: Josef Baumgartner <josef.baumgartner@br-automation.com>
-Date: Wed, 14 Aug 2013 10:22:21 +0200
-Subject: [PATCH 1/1] [FIX] Fix compilation issue for kernels > 3.5
-
-With kernel version 3.5 the interface of kmap_atomic() and
-kunmap_atomic is changed. The fix adapts to the new interface.
-
-Change-Id: I0885b87dc594bf48d1ff4eaeaf188268ceb3b112
-Reviewed-on: http://brateggevoat1/gerrit/1261
-Tested-by: Jenkins <jenkins@brateggevoat1.br-automation.co.at>
-Reviewed-by: Josef Baumgartner <josef.baumgartner@br-automation.com>
----
- EplStack/EplApiProcessImage.c | 24 +++++++++++++++++++-----
- 1 file changed, 19 insertions(+), 5 deletions(-)
-
-diff --git a/EplStack/EplApiProcessImage.c b/EplStack/EplApiProcessImage.c
-index a1a049f..02907bc 100644
---- a/EplStack/EplApiProcessImage.c
-+++ b/EplStack/EplApiProcessImage.c
-@@ -573,7 +573,7 @@ tEplApiProcessImageCopyJobInt   IntCopyJob;
- #elif (TARGET_SYSTEM == _WIN32_)
-     if (EplApiProcessImageInstance_g.m_dwCurrentThreadId == GetCurrentThreadId())
- #elif (TARGET_SYSTEM == _VXWORKS_)
--    if (EplApiProcessImageInstance_g.m_currentThreadId == taskIdSelf())       
-+    if (EplApiProcessImageInstance_g.m_currentThreadId == taskIdSelf())
- #else
- #error "OS currently not supported by EplApiProcessImage!"
- #endif
-@@ -1018,13 +1018,20 @@ void*           pVirtUserPart;
-             }
-
-             ulSize = min ((PAGE_SIZE - ulOffset), pPart->m_uiSize - ulLength);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,5,0)
-             pVirtUserPart = kmap_atomic(ppPage[nIndex], KM_USER0);
-+#else
-+            pVirtUserPart = kmap_atomic(ppPage[nIndex]);
-+#endif
-
-             EPL_MEMCPY(pPIVar,
-                 pVirtUserPart + ulOffset,
-                 ulSize);
--
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,5,0)
-             kunmap_atomic(pVirtUserPart, KM_USER0);
-+#else
-+            kunmap_atomic(pVirtUserPart);
-+#endif
-
-             pPIVar += ulSize;
-             ulLength += ulSize;
-@@ -1063,14 +1070,21 @@ void*           pVirtUserPart;
-             }
-
-             ulSize = min ((PAGE_SIZE - ulOffset), pPart->m_uiSize - ulLength);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,5,0)
-             pVirtUserPart = kmap_atomic(ppPage[nIndex], KM_USER0);
-+#else
-+            pVirtUserPart = kmap_atomic(ppPage[nIndex]);
-+#endif
-
-             EPL_MEMCPY(pVirtUserPart + ulOffset,
-                 pPIVar,
-                 ulSize);
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,5,0)
-             kunmap_atomic(pVirtUserPart, KM_USER0);
--
-+#else
-+            kunmap_atomic(pVirtUserPart);
-+#endif
-             pPIVar += ulSize;
-             ulLength += ulSize;
-             ulOffset = 0;
-
---
-1.8.4
-
diff --git a/package/openpowerlink/openpowerlink-0003-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch b/package/openpowerlink/openpowerlink-0003-Fix-Linux-Powerlink-user-lib-add-INSTALL.patch
deleted file mode 100644 (file)
index bed878e..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-From cb6c4ff053e72f7fe5954894aebe2c0d94120b2d Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Thu, 3 Oct 2013 23:22:17 +0200
-Subject: [PATCH 5/5] [FIX] Linux Powerlink user lib: add INSTALL
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
----
- Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
-index e67d573..40b7756 100644
---- a/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
-+++ b/Examples/X86/Generic/powerlink_user_lib/CMakeLists.txt
-@@ -329,7 +329,9 @@ ENDIF ()
- #
- # Installation
- #
--IF (WIN32)
-+IF (UNIX)
-+    INSTALL(TARGETS powerlink ARCHIVE DESTINATION lib)
-+ELSEIF (WIN32)
-     IF (CFG_X86_WINDOWS_DLL)
-         INSTALL(TARGETS openPOWERLINK RUNTIME DESTINATION bin)
-     ENDIF (CFG_X86_WINDOWS_DLL)
---
-1.8.4
-
index 5babdd65d041f5c07fda71c05b846991223d5a6a..3a60478a0d9783ae993959e7fc4120cedfd3dcaa 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-OPENPOWERLINK_VERSION = V1.08.3
+OPENPOWERLINK_VERSION = V1.08.4
 OPENPOWERLINK_SOURCE = openPOWERLINK-$(OPENPOWERLINK_VERSION).zip
-OPENPOWERLINK_SITE = http://downloads.sourceforge.net/project/openpowerlink/openPOWERLINK/V1.8.3
+OPENPOWERLINK_SITE = http://downloads.sourceforge.net/project/openpowerlink/openPOWERLINK/V1.8.4
 
 OPENPOWERLINK_LICENSE = BSD-2c, GPLv2
 OPENPOWERLINK_LICENSE_FILES = license.txt