If both bash and busybox are selected, make certain bash wins
authorEric Andersen <andersen@codepoet.org>
Mon, 27 Dec 2004 21:46:32 +0000 (21:46 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 27 Dec 2004 21:46:32 +0000 (21:46 -0000)
the fight over who gets to own the /bin/sh symlink
 -Erik

package/bash/bash.mk

index 704b45b73d706e17408d58264c5abc1c7d34be67..64f40d7be298607f38f9cd879f20619ade6e5ac6 100644 (file)
@@ -63,7 +63,13 @@ $(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
+#If both bash and busybox are selected, make certain bash wins
+#the fight over who gets to own the /bin/sh symlink
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+bash: ncurses uclibc busybox $(TARGET_DIR)/$(BASH_TARGET_BINARY)
+else
 bash: ncurses uclibc $(TARGET_DIR)/$(BASH_TARGET_BINARY)
+endif
 
 bash-clean:
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BASH_DIR) uninstall