package/perl-net-ssh2: fix gcrypt build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 11 Aug 2021 20:58:14 +0000 (22:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 12 Aug 2021 21:20:17 +0000 (23:20 +0200)
Pass crypto_backend option to avoid the following build failure raised
since bump to version 0.72 in commit
cd1d56bcde2a571062a1943c88506a8d9d2db357 and
https://github.com/rkitover/net-ssh2/commit/86a1274534dd7e0da03d98fb88c9c7ad4b1adb9b:

/tmp/instance-7/output-1/per-package/perl-net-ssh2/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/9.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: cannot find -lssl
/tmp/instance-7/output-1/per-package/perl-net-ssh2/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/9.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: cannot find -lcrypto

Fixes:
 - http://autobuild.buildroot.org/results/25747ec239e0b92775aa883e4f531f77d45f352e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/perl-net-ssh2/perl-net-ssh2.mk

index 5572e23257996d6ede2354d383ae9c7f0acd0708..20e45b6287e31aa5d22f70a8aff0114ce9422e4b 100644 (file)
@@ -18,7 +18,7 @@ PERL_NET_SSH2_CONF_OPTS += \
        inc="$(STAGING_DIR)/usr/include"
 
 ifeq ($(BR2_PACKAGE_LIBSSH2_LIBGCRYPT),y)
-PERL_NET_SSH2_CONF_OPTS += gcrypt
+PERL_NET_SSH2_CONF_OPTS += crypto_backend=gcrypt
 endif
 
 $(eval $(perl-package))