bustle: use TARGET_MAKE_ENV instead of setting PATH in the make environment
authorSamuel Martin <s.martin49@gmail.com>
Sat, 1 Mar 2014 19:59:08 +0000 (20:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 22:46:15 +0000 (23:46 +0100)
TARGET_MAKE_ENV already contains the PATH definition among other useful
variables.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bustle/bustle.mk

index 2330c08ac936dac86039868bd4f30b335fed18c7..7bc3e97bcf8c6d767cd04ee44b4b6790fd5a9571 100644 (file)
@@ -11,7 +11,7 @@ BUSTLE_LICENSE_FILES = LICENSE
 BUSTLE_DEPENDENCIES = libglib2 libpcap host-pkgconf
 
 define BUSTLE_BUILD_CMDS
-       PATH=$(TARGET_PATH) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
                PCAP_FLAGS='-lpcap' -C $(@D) dist/build/bustle-pcap
 endef