flex: fix configure cache issue with BR2_NEEDS_GETTEXT
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 13:04:59 +0000 (15:04 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 13:10:41 +0000 (15:10 +0200)
Flex doesn't NEED gettext/libintl, but it's configure script checks for it,
so make sure those a built before flex, otherwise flex will populate
tgt-config.cache with invalid values, breaking the build of other packages
needing it (like libglib2).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/flex/flex.mk

index ad3554822940a5630896f3ab390f201417a7840e..41c9505f3c3ac7fdcd0a11dea50483694be9bd0e 100644 (file)
@@ -10,6 +10,9 @@ FLEX_PATCH:=flex_$(FLEX_VERSION)-$(FLEX_PATCH_VERSION).diff.gz
 FLEX_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/f/flex
 FLEX_DIR:=$(BUILD_DIR)/flex-$(FLEX_VERSION)
 FLEX_INSTALL_STAGING=YES
+FLEX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_GETTEXT),gettext) \
+       $(if $(BR2_PACKAGE_LIBINTL),libintl)
 
 # lex -> flex
 define FLEX_INSTALL_LEX