link $(STAGING_DIR)/usr/lib to $(STAGING_DIR)/lib
authorEric Andersen <andersen@codepoet.org>
Wed, 10 Jan 2007 06:55:27 +0000 (06:55 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 10 Jan 2007 06:55:27 +0000 (06:55 -0000)
to make glib2 (and packages with similar confusion) work
properly, while still being able to cross compile

Makefile

index 6782a8228d7e5e15afa70dc11eec61de396803da..78f2f00718dab9f0d3d35225e65d707da5a88f15 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,9 @@ $(TOOL_BUILD_DIR):
 $(STAGING_DIR):
        @mkdir -p $(STAGING_DIR)/lib
        @mkdir -p $(STAGING_DIR)/include
+       @mkdir -p $(STAGING_DIR)/usr
        @mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
+       @ln -snf ../lib $(STAGING_DIR)/usr/lib
        @ln -snf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
 
 $(TARGET_DIR):