package/libcap: disable GOLANG
authorTian Yuanhao <tianyuanhao@aliyun.com>
Mon, 31 Aug 2020 02:16:41 +0000 (10:16 +0800)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 9 Sep 2020 20:38:23 +0000 (22:38 +0200)
Recently, the go infrastructure has changed, and libcap has been
upgraded to 2.42. libcap introduced golang in 2.28, see:

https://git.kernel.org/pub/scm/linux/kernel/git/morgan/libcap.git/commit/Make.Rules?id=0615d996379dceedefcd65a114f93fefd81c208f

When you compile host-go and then compile host-libcap, GOLANG will be
automatically set to yes. Because libcap.mk lacks golang support,
compilation will fail.

Signed-off-by: Tian Yuanhao <tianyuanhao@aliyun.com>
Tested-by: Joseph Kogut <joseph.kogut@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libcap/libcap.mk

index 08c1bc9deb175c04f1d6c6f522cc19cfcad30d4d..e16e4ed4130138c52c5306346bf605b12edcabd5 100644 (file)
@@ -62,12 +62,12 @@ endef
 
 define HOST_LIBCAP_BUILD_CMDS
        $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)\
-               RAISE_SETFCAP=no
+               RAISE_SETFCAP=no GOLANG=no
 endef
 
 define HOST_LIBCAP_INSTALL_CMDS
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D) prefix=$(HOST_DIR) \
-               RAISE_SETFCAP=no lib=lib install
+               RAISE_SETFCAP=no GOLANG=no lib=lib install
 endef
 
 $(eval $(generic-package))