python-cchardet: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 11 Nov 2018 23:23:12 +0000 (07:23 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 13 Nov 2018 21:44:02 +0000 (22:44 +0100)
cChardet is high speed universal character encoding detector.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-cchardet/Config.in [new file with mode: 0644]
package/python-cchardet/python-cchardet.hash [new file with mode: 0644]
package/python-cchardet/python-cchardet.mk [new file with mode: 0644]

index 53505314d7b608011ebbd1ac6683515bdd9b8c9a..85621fcc97eefdc332d5c040f7e8fb7cc3d0e92d 100644 (file)
@@ -986,6 +986,7 @@ F:  configs/pine64_sopine_defconfig
 N:     James Hilliard <james.hilliard1@gmail.com>
 F:     package/python-aiodns/
 F:     package/python-async-timeout/
+F:     package/python-cchardet/
 F:     package/python-multidict/
 F:     package/python-pycares/
 F:     package/python-yarl/
index e1c87aee25ad7832a699a88c7d25d64de1b92d41..3f2478e6b7d6b96fe4401924c7a5fb0954904a06 100644 (file)
@@ -814,6 +814,7 @@ menu "External python modules"
        source "package/python-cached-property/Config.in"
        source "package/python-can/Config.in"
        source "package/python-cbor/Config.in"
+       source "package/python-cchardet/Config.in"
        source "package/python-certifi/Config.in"
        source "package/python-cffi/Config.in"
        source "package/python-characteristic/Config.in"
diff --git a/package/python-cchardet/Config.in b/package/python-cchardet/Config.in
new file mode 100644 (file)
index 0000000..7415312
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PYTHON_CCHARDET
+       bool "python-cchardet"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         cChardet is high speed universal character encoding
+         detector.
+
+         https://github.com/PyYoshi/cChardet
+
+comment "python-cchardet needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/python-cchardet/python-cchardet.hash b/package/python-cchardet/python-cchardet.hash
new file mode 100644 (file)
index 0000000..231804e
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/cchardet/json
+md5    17af20af67cb18e958854e273d857a88  cchardet-2.1.4.tar.gz
+sha256 cc9745e0400da4cfb49f075e7819f22473b66443f953427058fee2c7b9547cc0  cchardet-2.1.4.tar.gz
+# Locally computed sha256 checksums
+sha256 107a29ccdd2d778aa2df5462f85dddfa099059abd22e064e07ec2cc9bafc37cd  COPYING
diff --git a/package/python-cchardet/python-cchardet.mk b/package/python-cchardet/python-cchardet.mk
new file mode 100644 (file)
index 0000000..9ac170c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-cchardet
+#
+################################################################################
+
+PYTHON_CCHARDET_VERSION = 2.1.4
+PYTHON_CCHARDET_SOURCE = cchardet-$(PYTHON_CCHARDET_VERSION).tar.gz
+PYTHON_CCHARDET_SITE = https://files.pythonhosted.org/packages/74/64/3988d388315c1af3e24f447689dadf30edead43366fb2041cb103380b57f
+PYTHON_CCHARDET_SETUP_TYPE = setuptools
+PYTHON_CCHARDET_LICENSE = MPL-1.1
+PYTHON_CCHARDET_LICENSE_FILES = COPYING
+
+$(eval $(python-package))