fcgiwrap: Add a patch to link with libsystemd, not libsystemd-daemon.
authorThomas Claveirole <thomas.claveirole@green-communications.fr>
Mon, 18 Jul 2016 14:28:50 +0000 (16:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Jul 2016 21:20:09 +0000 (23:20 +0200)
Fixes:

  http://autobuild.buildroot.org/results/9b5e70e42e53e7752245f7c43bd01f208fcf76d0/

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fcgiwrap/0002-link-with-libsystemd-instead-of-libsystemd-daemon.patch [new file with mode: 0644]

diff --git a/package/fcgiwrap/0002-link-with-libsystemd-instead-of-libsystemd-daemon.patch b/package/fcgiwrap/0002-link-with-libsystemd-instead-of-libsystemd-daemon.patch
new file mode 100644 (file)
index 0000000..e88706f
--- /dev/null
@@ -0,0 +1,20 @@
+configure.ac: Check for libsystemd, not libsystemd-daemon.
+
+Newer versions of systemd do not provide libsystemd-daemon anymore.
+Therefore, use libsystemd instead.
+
+Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
+
+diff --git a/configure.ac b/configure.ac
+index bb3674e..2b02ef4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,7 +28,7 @@ AC_ARG_WITH([systemd],
+   [], [with_systemd=check])
+ have_systemd=no
+ if test "x$with_systemd" != "xno"; then
+-  PKG_CHECK_MODULES(systemd, [libsystemd-daemon],
++  PKG_CHECK_MODULES(systemd, [libsystemd],
+     [AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd is available])
+     have_systemd=yes],
+   have_systemd=no)