core/pkg-generic: host variants inherits target's override-srcdir
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Jul 2015 13:15:28 +0000 (15:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Jul 2015 13:30:48 +0000 (15:30 +0200)
When a package has both a target and a host variants, and there is an
override-srcdir set for the target variant, the host variant should
inherit the target's override-srcdir, unless explicitly set, like we do
for all other target-variant properties.

However, do not override it if expressly set to empty (i.e. when the
user wants to override only the target variant).

Also, as we do for the other variables, the target variant never
inherits from the host variant.

Reported-by: Mike <mikez@OpenPlayer.org>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tested-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 75dc8b7e69a710c94d4e522e84482d89e0f8803e..6a7d97efdf02071c0c3f61fde1b2292fcc18e5fa 100644 (file)
@@ -340,6 +340,10 @@ else
 endif
 $(2)_VERSION := $$(call sanitize,$$($(2)_DL_VERSION))
 
+ifdef $(3)_OVERRIDE_SRCDIR
+  $(2)_OVERRIDE_SRCDIR ?= $$($(3)_OVERRIDE_SRCDIR)
+endif
+
 $(2)_BASE_NAME =  $(1)-$$($(2)_VERSION)
 $(2)_DL_DIR    =  $$(DL_DIR)/$$($(2)_BASE_NAME)
 $(2)_DIR       =  $$(BUILD_DIR)/$$($(2)_BASE_NAME)