package/libgpgme: properly tweak gpgme-config
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 11 Dec 2018 15:24:25 +0000 (16:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:48:51 +0000 (21:48 +0100)
libgpgme installs a gpgme-config script, it should be tweaked using
the <pkg>_CONFIG_SCRIPTS mechanism. This is generally useful and is
going to be particularly important with per-package directories.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libgpgme/libgpgme.mk

index a70ffcf11d2fa8f8358bc7237200d3006bf53447..85450c83d2df56a730e2ac502aec0784e70a7f63 100644 (file)
@@ -12,6 +12,7 @@ LIBGPGME_LICENSE_FILES = COPYING.LESSER
 LIBGPGME_INSTALL_STAGING = YES
 LIBGPGME_DEPENDENCIES = libassuan libgpg-error
 LIBGPGME_LANGUAGE_BINDINGS = cl
+LIBGPGME_CONFIG_SCRIPTS = gpgme-config
 
 LIBGPGME_CONF_OPTS = \
        --with-gpg-error-prefix=$(STAGING_DIR)/usr \