Add libxpm as a dependency of ace_of_penguins
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 14 Feb 2010 13:20:45 +0000 (14:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 18 Feb 2010 23:35:24 +0000 (00:35 +0100)
ace_of_penguins fails to build when xlib_libXpm is not selected. Add
it has a dependency. However, contrary to normal dependencies to
libraries (where we use 'select') we use 'depends on' here, otherwise
the X.org server will be get selected automatically without the user
noticing.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/games/ace_of_penguins/Config.in
package/games/ace_of_penguins/ace_of_penguins.mk

index edbaf26ce765ddd887139aa7c9db605e0fd8540d..1d5a36774199fcc5bb752f7a8ddd4835bca95e74 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_ACE_OF_PENGUINS
        bool "ace_of_penguins"
        select BR2_PACKAGE_LIBPNG
        depends on BR2_PACKAGE_XORG7
+       depends on BR2_PACKAGE_XLIB_LIBXPM
        help
          The Ace of Penguins is a set of Unix/X solitaire games based
          on the ones available for Windows but with a number of
index 65a2667af3b951342e0123e5185e7d8d6f0972b9..fe3e20481a4f216d5ba74a2add377e54aa292a6e 100644 (file)
@@ -10,6 +10,6 @@ ACE_OF_PENGUINS_AUTORECONF = YES
 ACE_OF_PENGUINS_STAGING = NO
 ACE_OF_PENGUINS_TARGET = YES
 
-ACE_OF_PENGUINS_DEPENDENCIES = libpng xserver_xorg-server
+ACE_OF_PENGUINS_DEPENDENCIES = libpng xserver_xorg-server xlib_libXpm
 
 $(eval $(call AUTOTARGETS,package/games,ace_of_penguins))