package/systemd: add optional support for hibernation
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:15 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 11:00:56 +0000 (13:00 +0200)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 80796d2190b8d70fce0c0efda124233f637f2d4a..dcabf3b456a894aaf61fd4abb3899055999ad17b 100644 (file)
@@ -314,4 +314,12 @@ config BR2_PACKAGE_SYSTEMD_SMACK_SUPPORT
          When this feature is enabled, Systemd mounts smackfs and manages
          security labels for sockets.
 
+config BR2_PACKAGE_SYSTEMD_HIBERNATE
+       bool "enable hibernation support"
+       help
+         When this features is enabled, additional tools and services
+         are built to support suspending and resuming the system.
+
+         http://www.freedesktop.org/software/systemd/man/systemd-sleep.html
+
 endif
index 5b0aa01b9512ed78c56a1642614569ab926afce2..96c34a4c99ccea71a391c5b7cc6643dbb4ed7cbc 100644 (file)
@@ -277,6 +277,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-smack
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_HIBERNATE),y)
+SYSTEMD_CONF_OPTS += --enable-hibernate
+else
+SYSTEMD_CONF_OPTS += --disable-hibernate
+endif
+
 # mq_getattr needs -lrt
 SYSTEMD_MAKE_OPTS += LIBS=-lrt
 SYSTEMD_MAKE_OPTS += LDFLAGS+=-ldl