add pcre
authorJohn Voltz <john.voltz@gmail.com>
Thu, 24 Apr 2008 16:56:06 +0000 (16:56 -0000)
committerJohn Voltz <john.voltz@gmail.com>
Thu, 24 Apr 2008 16:56:06 +0000 (16:56 -0000)
package/Config.in
package/pcre/Config.in [new file with mode: 0644]
package/pcre/pcre.mk [new file with mode: 0644]

index eddde49e9d70ca972752996df2ab402a2e2e56ae..53d312c50ed0139251dbdad4a7aa88fda5f94299 100644 (file)
@@ -56,6 +56,7 @@ source "package/oprofile/Config.in"
 source "package/pkgconfig/Config.in"
 source "package/readline/Config.in"
 source "package/valgrind/Config.in"
+source "package/pcre/Config.in"
 
 comment "Other stuff"
 source "package/at/Config.in"
diff --git a/package/pcre/Config.in b/package/pcre/Config.in
new file mode 100644 (file)
index 0000000..d26a271
--- /dev/null
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_PCRE
+       bool "pcre"
+       default n
+       help
+         Perl Compatible Regular Expressions
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
new file mode 100644 (file)
index 0000000..f6f7003
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# PCRE
+#
+#############################################################
+PCRE_VERSION = 7.6
+PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
+PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
+PCRE_INSTALL_STAGING = YES
+PCRE_INSTALL_TARGET = YES
+
+PCRE_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+        --build=$(GNU_HOST_NAME) --prefix=/usr \
+        --includedir=/usr/include
+
+PCRE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,pcre))