package/pmake: force argv[0]=${0} in the pmake wrapper
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 14 May 2013 11:45:57 +0000 (11:45 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 20:33:05 +0000 (22:33 +0200)
This forces bmake to call the wrapper, not itself.
Also, use consistent "${0/*}" instead of "${0/pmake}".

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pmake/pmake.mk

index 7b2e5a6efab65e11d4e0e966b5d970d81c004c31..50613e8d4d8b110cfaf081e8acac5f10d36dbe78 100644 (file)
@@ -39,7 +39,7 @@ define HOST_PMAKE_INSTALL_CMDS
        for mk in $(@D)/mk/*; do                                        \
            $(INSTALL) -m 0644 $${mk} $(HOST_DIR)/usr/share/pmake/mk;   \
        done
-       printf '#!/bin/sh\nexec $${0%%/*}/bmake -m $${0%%/pmake}/../../usr/share/pmake/mk "$$@"\n'  \
+       printf '#!/bin/bash\nexec -a "$${0}" $${0%%/*}/bmake -m $${0%%/*}/../../usr/share/pmake/mk "$$@"\n'  \
               >$(HOST_DIR)/usr/bin/pmake
        chmod 0755 $(HOST_DIR)/usr/bin/pmake
 endef