package/lm-sensors: disable static library for shared-only build
authorRomain Naour <romain.naour@openwide.fr>
Sat, 27 Dec 2014 21:58:19 +0000 (22:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Dec 2014 21:20:09 +0000 (22:20 +0100)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lm-sensors/lm-sensors.mk

index a79977f607c9cc9b8bd479c7a2b187abecc28e2c..c26f91918d2af71243c5cd356b961861ab65fe5e 100644 (file)
@@ -31,6 +31,12 @@ else
 LM_SENSORS_MAKE_OPTS += BUILD_SHARED_LIB=1
 endif
 
+ifeq ($(BR2_SHARED_LIBS),y)
+LM_SENSORS_MAKE_OPTS += BUILD_STATIC_LIB=0
+else
+LM_SENSORS_MAKE_OPTS += BUILD_STATIC_LIB=1
+endif
+
 define LM_SENSORS_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) $(LM_SENSORS_MAKE_OPTS) -C $(@D)
 endef