DOWNLOAD: don't use := assignment for function implementation
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jan 2009 12:30:07 +0000 (12:30 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 16 Jan 2009 12:30:07 +0000 (12:30 -0000)
:= causes the function parameters to get evaluated at definition time
instead of implementation time, which is kind of silly for a function.

Fixes make source-check / external-deps

package/Makefile.autotools.in

index bd8bed4bb7fb13ab53f7814d8084a5b9a1337002..6753f68b18755df94246a1c3f2ab2b09c34acd72 100644 (file)
@@ -134,7 +134,7 @@ TERM_RESET := $(shell tput rmso)
 
 # support make source-check/external-deps
 ifneq ($(SPIDER),)
-DOWNLOAD:=$(WGET) -P $(DL_DIR) $(1)/$(2)
+DOWNLOAD=$(WGET) -P $(DL_DIR) $(1)/$(2)
 else
 define DOWNLOAD
        $(Q)test -e $(DL_DIR)/$(2) || \