projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
79a40a3
)
Support gcc 4.[01]. Only tried for 4.0.0 at this point.
author
Manuel Novoa III
<mjn3@codepoet.org>
Sat, 30 Apr 2005 21:58:58 +0000
(21:58 -0000)
committer
Manuel Novoa III
<mjn3@codepoet.org>
Sat, 30 Apr 2005 21:58:58 +0000
(21:58 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk
patch
|
blob
|
history
diff --git
a/toolchain/gcc/gcc-uclibc-3.x.mk
b/toolchain/gcc/gcc-uclibc-3.x.mk
index d5babd263bf4e1a4b3e27a5dfbb703c0dbb76a38..3f731eb1fcaa5fd1bd6e348bab04491beca1ee23 100644
(file)
--- a/
toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/
toolchain/gcc/gcc-uclibc-3.x.mk
@@
-285,6
+285,13
@@
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
else
GCC_LIB_SUBDIR=lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
endif
+# sigh... we need to find a better way
+ifeq ($(findstring 4.0.,$(GCC_VERSION)),4.0.)
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+endif
+ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+endif
$(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
PATH=$(TARGET_PATH) \