package/zbar: needs c99 mode
authorPeter Seiderer <ps.report@gmx.net>
Wed, 27 Feb 2019 22:01:00 +0000 (23:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 28 Feb 2019 22:40:30 +0000 (23:40 +0100)
Fixes [1]:

  bar/sqcode.c: In function 'sq_scan_shape':
  zbar/sqcode.c:171:5: error: 'for' loop initial declarations are only allowed in C99 or C11 mode
       for (int x = x0 - 1; x < x0 + width + 1; x++) {
       ^
  zbar/sqcode.c:171:5: note: use option -std=c99, -std=gnu99, -std=c11 or -std=gnu11 to compile your code

[1] http://autobuild.buildroot.net/results/7d544275756f655f9d42c05562aca653923155b1

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/zbar/zbar.mk

index 6df069e001ff289cb0b4306f0c844f1f2704d269..c3f0797c554dadb88fe34c64033537d759b69864 100644 (file)
@@ -13,6 +13,8 @@ ZBAR_AUTORECONF = YES
 ZBAR_DEPENDENCIES = libv4l jpeg
 # add host-gettext for AM_ICONV macro
 ZBAR_DEPENDENCIES += host-gettext
+# uses C99 features
+ZBAR_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
 ZBAR_CONF_OPTS = \
        --disable-doc \
        --without-imagemagick \