package/uclibc: check for config file
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 13 Jul 2015 10:32:04 +0000 (12:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 08:31:50 +0000 (10:31 +0200)
Add a check (before we call kconfig-package) that ensures the user has
set a kconfig-file.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index ecbfa113d403ac4cfb2940774cdb16da864cde84..3aceae300cce85440df31965b09ed596cb591c55 100644 (file)
@@ -474,4 +474,12 @@ define UCLIBC_INSTALL_STAGING_CMDS
        $(UCLIBC_INSTALL_UTILS_STAGING)
 endef
 
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
+ifeq ($(BR_BUILDING),y)
+ifeq ($(call qstrip,$(BR2_UCLIBC_CONFIG)),)
+$(error No uClibc configuration file specified, check your BR2_UCLIBC_CONFIG setting)
+endif
+endif
+
 $(eval $(kconfig-package))