Add support for plain URL in $(PKG)_PATCH variable
authorJérôme Pouiller <jezz@sysmic.org>
Mon, 13 May 2013 15:51:52 +0000 (17:51 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 6 Sep 2013 21:54:18 +0000 (23:54 +0200)
Until now, $(PKG)_PATCH allow only to download patches from same URL than tarball.
This patch allow to detect when plain URL are used in $(PKG)_PATCH and correctly
handle them.

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Markos Chandras <markos.chandras@imgtec.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-generic.mk

index 00f1cb31d2e5f3b8008495e36f9e190dd30ae6b8..4dd395b6ea9da32173ddab88e3f863f06b86d995 100644 (file)
@@ -40,7 +40,12 @@ ifeq ($(DL_MODE),DOWNLOAD)
        fi
 endif
        $(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$($(PKG)_SOURCE)))
-       $(foreach p,$($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE:/=)/$(p))$(sep))
+       $(foreach p,$($(PKG)_PATCH),\
+               $(if $(findstring ://,$(p)),\
+                       $(call DOWNLOAD,$(p)),\
+                       $(call DOWNLOAD,$($(PKG)_SITE:/=)/$(p))\
+               )\
+       $(sep))
        $(foreach hook,$($(PKG)_POST_DOWNLOAD_HOOKS),$(call $(hook))$(sep))
 ifeq ($(DL_MODE),DOWNLOAD)
        $(Q)mkdir -p $(@D)
@@ -86,7 +91,7 @@ $(BUILD_DIR)/%/.stamp_patched: PATCH_BASE_DIRS = $($(PKG)_DIR_PREFIX)/$(RAWNAME)
 $(BUILD_DIR)/%/.stamp_patched:
        @$(call MESSAGE,"Patching $($(PKG)_DIR_PREFIX)/$(RAWNAME)")
        $(foreach hook,$($(PKG)_PRE_PATCH_HOOKS),$(call $(hook))$(sep))
-       $(foreach p,$($(PKG)_PATCH),support/scripts/apply-patches.sh $(@D) $(DL_DIR) $(p)$(sep))
+       $(foreach p,$($(PKG)_PATCH),support/scripts/apply-patches.sh $(@D) $(DL_DIR) $(notdir $(p))$(sep))
        $(Q)( \
        for D in $(PATCH_BASE_DIRS); do \
          if test -d $${D}; then \