ti-cgt-pru: use HOST_TI_CGT_PRU_DL_DIR instead of TI_CGT_PRU_DL_DIR
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Mon, 2 Apr 2018 18:36:25 +0000 (20:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 18:50:54 +0000 (20:50 +0200)
The infrastructure only provides HOST_TI_CGT_PRU_DL_DIR, because this
package is host only. Ideally the infra should provide TI_CGT_PRU_DL_DIR,
but it doesn't currently, and that requires more significant changes.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ti-cgt-pru/ti-cgt-pru.mk

index df3b97bef561420cc7402180c360dc412b2d85ab..3665d2cec8eda5a2c217d0b882641ac35bd60363 100644 (file)
@@ -13,8 +13,8 @@ TI_CGT_PRU_LICENSE_FILES = PRU_Code_Generation_Tools_2.2.x_manifest.html \
        pru_rts_2_2_0_82167478-F8C9-49b2-82BD-12F8550770F9.spdx
 
 define HOST_TI_CGT_PRU_EXTRACT_CMDS
-       chmod +x $(TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE)
-       $(TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE) --prefix $(@D) --mode unattended
+       chmod +x $(HOST_TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE)
+       $(HOST_TI_CGT_PRU_DL_DIR)/$(TI_CGT_PRU_SOURCE) --prefix $(@D) --mode unattended
        mv $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/* $(@D)
        rmdir $(@D)/ti-cgt-pru_$(TI_CGT_PRU_VERSION)/
 endef