barebox/u-boot/linux: don't error out on missing config when make source
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 Sep 2010 12:43:25 +0000 (14:43 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 Sep 2010 12:43:25 +0000 (14:43 +0200)
As it breaks 'make allyesconfig; make source', used for the source mirror.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/barebox/barebox.mk
boot/u-boot/u-boot.mk
linux/linux.mk

index 7c2cbc123e8e30381faacad0a63f4cb2866a8445..85224cae0f5952570cc0ca7f98a2471c142b6c4c 100644 (file)
@@ -53,9 +53,11 @@ barebox: $(BAREBOX_DIR)/.installed
 ifeq ($(BR2_TARGET_BAREBOX),y)
 TARGETS+=barebox
 
-# we NEED a board defconfig file
+# we NEED a board defconfig file unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
 ifeq ($(BAREBOX_BOARD_DEFCONFIG),)
 $(error No Barebox defconfig file. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG setting)
 endif
+endif
 
 endif
index f97674ada68944e4f707272e0dee5267a8c79ced..971920751492c9865f006ee099753a681df1127d 100644 (file)
@@ -193,9 +193,11 @@ u-boot-configured: $(U_BOOT_DIR)/.header_modified
 ifeq ($(BR2_TARGET_UBOOT),y)
 TARGETS+=u-boot
 
-# we NEED a board name
+# we NEED a board name unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
 ifeq ($(U_BOOT_BOARD_NAME),)
 $(error NO U-Boot board name set. Check your BR2_TARGET_UBOOT_BOARDNAME setting)
 endif
+endif
 
 endif
index ea338fc5c581edd281f4500878bed3c644732b3b..aabecc1f65c9afc88d8cb1d33931025baa00aae8 100644 (file)
@@ -159,6 +159,7 @@ TARGETS+=linux26
 endif
 
 # Checks to give errors that the user can understand
+ifeq ($(filter source,$(MAKECMDGOALS)),)
 ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
 ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
 $(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)
@@ -169,4 +170,6 @@ ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
 ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)),)
 $(error No kernel configuration file specified, check your BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE setting)
 endif
-endif
\ No newline at end of file
+endif
+
+endif