m4: bump to version 1.4.16
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 13 Nov 2011 22:27:54 +0000 (19:27 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Nov 2011 08:29:49 +0000 (09:29 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/m4/m4-1.4.15-uclibc-sched_param-def.patch [deleted file]
package/m4/m4-1.4.16-001-MB_CUR_MAX.patch [new file with mode: 0644]
package/m4/m4-1.4.8-001-MB_CUR_MAX.patch [deleted file]
package/m4/m4.mk

diff --git a/package/m4/m4-1.4.15-uclibc-sched_param-def.patch b/package/m4/m4-1.4.15-uclibc-sched_param-def.patch
deleted file mode 100644 (file)
index 47bdd3d..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
-and is not needed too per standard. gnulib attempts to use it but we have to account
-for it because in this case uclibc does not behave like glibc.
-
--Khem
-
-Index: m4-1.4.14/lib/spawn.in.h
-===================================================================
---- m4-1.4.14.orig/lib/spawn.in.h      2010-06-01 14:27:59.394242980 -0700
-+++ m4-1.4.14/lib/spawn.in.h   2010-06-01 14:28:28.202332200 -0700
-@@ -31,7 +31,7 @@
- /* Get definitions of 'struct sched_param' and 'sigset_t'.
-    But avoid namespace pollution on glibc systems.  */
--#ifndef __GLIBC__
-+#if !defined __GLIBC__ || defined __UCLIBC__
- # include <sched.h>
- # include <signal.h>
- #endif
diff --git a/package/m4/m4-1.4.16-001-MB_CUR_MAX.patch b/package/m4/m4-1.4.16-001-MB_CUR_MAX.patch
new file mode 100644 (file)
index 0000000..fce3673
--- /dev/null
@@ -0,0 +1,13 @@
+--- m4-1.4.8.orig/lib/regcomp.c        2006-09-24 06:28:37.000000000 +0200
++++ m4-1.4.8/lib/regcomp.c     2007-01-06 20:53:10.000000000 +0100
+@@ -871,6 +871,10 @@ init_dfa (re_dfa_t *dfa, size_t pat_len)
+   dfa->state_table = calloc (sizeof (struct re_state_table_entry), table_size);
+   dfa->state_hash_mask = table_size - 1;
++#ifndef MB_CUR_MAX
++#define MB_CUR_MAX (0)
++#endif
++
+   dfa->mb_cur_max = MB_CUR_MAX;
+ #ifdef _LIBC
+   if (dfa->mb_cur_max == 6
diff --git a/package/m4/m4-1.4.8-001-MB_CUR_MAX.patch b/package/m4/m4-1.4.8-001-MB_CUR_MAX.patch
deleted file mode 100644 (file)
index fce3673..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- m4-1.4.8.orig/lib/regcomp.c        2006-09-24 06:28:37.000000000 +0200
-+++ m4-1.4.8/lib/regcomp.c     2007-01-06 20:53:10.000000000 +0100
-@@ -871,6 +871,10 @@ init_dfa (re_dfa_t *dfa, size_t pat_len)
-   dfa->state_table = calloc (sizeof (struct re_state_table_entry), table_size);
-   dfa->state_hash_mask = table_size - 1;
-+#ifndef MB_CUR_MAX
-+#define MB_CUR_MAX (0)
-+#endif
-+
-   dfa->mb_cur_max = MB_CUR_MAX;
- #ifdef _LIBC
-   if (dfa->mb_cur_max == 6
index 4f18aa47c93b4f66caaa0ba672a563ccc3e448b1..173bba85c5f0b4280b96733f6f9d31a7ed18427a 100644 (file)
@@ -3,10 +3,10 @@
 # m4
 #
 #############################################################
-M4_VERSION = 1.4.15
+
+M4_VERSION = 1.4.16
 M4_SOURCE = m4-$(M4_VERSION).tar.bz2
 M4_SITE = $(BR2_GNU_MIRROR)/m4
-
 M4_CONF_ENV = gl_cv_func_gettimeofday_clobber=no
 
 ifneq ($(BR2_USE_WCHAR),y)