package/nginx: add stream geo option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 22 Jun 2020 19:31:13 +0000 (21:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Jun 2020 20:44:33 +0000 (22:44 +0200)
stream geo module has been added in version 1.11.3 with
https://github.com/nginx/nginx/commit/bb790f5d30025b634673fcb9939ded5b0c60301f
and is enabled by default, add an option to be able to disable it

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index cad5903882c9ed3e9181792024e3e5805c859ef3..09af4680ee51fce5f4660933f6db032acda74533 100644 (file)
@@ -346,6 +346,12 @@ config BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE
        help
          Enable ngx_stream_access_module
 
+config BR2_PACKAGE_NGINX_STREAM_GEO_MODULE
+       bool "ngx_stream_geo_module"
+       default y
+       help
+         Enable ngx_stream_geo_module
+
 config BR2_PACKAGE_NGINX_STREAM_MAP_MODULE
        bool "ngx_stream_map_module"
        default y
index 344d41d410b7d24db8355c9fcedeb464e77edd58..9fdc53fc2a20f8d7243166b20dbbdae9dddd94bd 100644 (file)
@@ -232,6 +232,7 @@ endif
 NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_GEO_MODULE),,--without-stream_geo_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_MAP_MODULE),,--without-stream_map_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_RETURN_MODULE),,--without-stream_return_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE),,--without-stream_upstream_hash_module) \