package/qemu: add optional usb-redir support
authorJared Bents <jared.bents@rockwellcollins.com>
Tue, 14 Jul 2020 16:57:50 +0000 (11:57 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Jul 2020 20:19:04 +0000 (22:19 +0200)
Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/qemu.mk

index a68f37542c0d32d52060ee7ba7a7776c17b8cb42..c2872a2748b1f3015722c37054e9c93cf217d687 100644 (file)
@@ -140,6 +140,13 @@ else
 QEMU_OPTS += --disable-spice
 endif
 
+ifeq ($(BR2_PACKAGE_USBREDIR),y)
+QEMU_OPTS += --enable-usb-redir
+QEMU_DEPENDENCIES += usbredir
+else
+QEMU_OPTS += --disable-usb-redir
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define QEMU_CONFIGURE_CMDS
@@ -172,7 +179,6 @@ define QEMU_CONFIGURE_CMDS
                        --disable-docs \
                        --disable-rbd \
                        --disable-libiscsi \
-                       --disable-usb-redir \
                        --disable-strip \
                        --disable-sparse \
                        --disable-mpath \