libevdev: disable runtime tests
authorPeter Seiderer <ps.report@gmx.net>
Sun, 11 Oct 2015 21:56:33 +0000 (23:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Oct 2015 19:18:59 +0000 (21:18 +0200)
Add new configure option '--disable-runtime-tests' and use it do
disable runtime tests which fail to compile on some uclibc
configurations.

Fixes [1], [2]:
  test-libevdev-init.c: In function 'test_set_clock_id':
  test-libevdev-init.c:493: error: 'CLOCK_MONOTONIC_RAW' undeclared (first use in this function)

and compile failure for !BR2_USE_MMU configuration:
  test-main.c:(.text+0x8): undefined reference to `_fork'

[1] http://autobuild.buildroot.net/results/0d0/0d0a987471ce8e9f76fc96e0ae8f0bfeadb45028/
[2] http://autobuild.buildroot.net/results/939/9392033f1b8d2c8e4e8791c90918dabbe28a7067/

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libevdev/0001-configure-add-disable-runtime-tests-option.patch [new file with mode: 0644]
package/libevdev/libevdev.mk

diff --git a/package/libevdev/0001-configure-add-disable-runtime-tests-option.patch b/package/libevdev/0001-configure-add-disable-runtime-tests-option.patch
new file mode 100644 (file)
index 0000000..405dff0
--- /dev/null
@@ -0,0 +1,42 @@
+From 95527e43845a5063a6125d7779a30d44c3b437ac Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Sun, 11 Oct 2015 13:33:19 +0200
+Subject: [PATCH] configure: add '--disable-runtime-tests' option
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ configure.ac | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 54a2510..286737b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,7 +74,14 @@ else
+       AC_MSG_WARN([check not found - skipping building unit tests])
+ fi
+ AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
+-AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x$HAVE_CHECK" = "xyes"])
++
++AC_ARG_ENABLE([runtime-tests],
++      AS_HELP_STRING([--disable-runtime-tests], [Disable runtime tests]))
++AS_IF([test "x$enable_runtime_tests" != "xno"],
++      [enable_runtime_tests=yes],
++      [enable_runtime_tests=no])
++
++AM_CONDITIONAL(ENABLE_RUNTIME_TESTS, [test "x${enable_runtime_tests}x$HAVE_CHECK" = "xyesxyes"])
+ AM_CONDITIONAL(ENABLE_STATIC_LINK_TEST, [test "x$enable_static" = "xyes"])
+ with_cflags=""
+@@ -159,7 +166,7 @@ AC_MSG_RESULT([
+              Libdir                           ${libdir}
+              Build documentation              ${have_doxygen}
+-             Enable unit-tests                ${HAVE_CHECK}
++             Enable unit-tests                ${HAVE_CHECK} (runtime-tests: ${enable_runtime_tests})
+              Enable profiling                 ${enable_gcov}
+              Static library symbol check      ${static_symbol_leaks_test}
+              ])
+-- 
+2.1.4
+
index d9a2be68083479be1230bec8b52e80a0e7e9964a..97d8a92e2f57e2b358a83cafe1b8b5a5b56178fb 100644 (file)
@@ -10,9 +10,14 @@ LIBEVDEV_SOURCE = libevdev-$(LIBEVDEV_VERSION).tar.xz
 LIBEVDEV_LICENSE = X11
 LIBEVDEV_LICENSE_FILES = COPYING
 
+# patch touches configure.ac
+LIBEVDEV_AUTORECONF = YES
+
 # Uses PKG_CHECK_MODULES() in configure.ac
 LIBEVDEV_DEPENDENCIES = host-pkgconf
 
 LIBEVDEV_INSTALL_STAGING = YES
 
+LIBEVDEV_CONF_OPTS += --disable-runtime-tests
+
 $(eval $(autotools-package))