xvkbd: turn into a generic-package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Jan 2013 11:29:38 +0000 (11:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 12 Jan 2013 21:52:01 +0000 (22:52 +0100)
xvkbd was integrated has an autotools package, but it does not have a
./configure script. And to avoid executing the ./configure, the
xvkbd-2.8-makefile.patch was creating a dummy .stamp_configured stamp
file... Ugly.

So, make xvkbd a normal generic package, with BUILD_CMDS and
INSTALL_TARGET_CMDS, and get rid of the crappy part of the patch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/xvkbd/xvkbd-2.8-makefile.patch
package/xvkbd/xvkbd.mk

index e0ac21afc11f88e92c530a3a0d06659c17995eb7..a8f65773871e1078c97cdffa8c506fee554ee69e 100644 (file)
@@ -1,8 +1,3 @@
---- a/.stamp_configured        2008-03-04 06:14:55.425005441 -0500
-+++ b/.stamp_configured        2008-03-05 08:42:53.000000000 -0500
-@@ -0,0 +1 @@
-+dummy
-\ No newline at end of file
 --- a/Makefile 2008-03-04 06:14:55.425005441 -0500
 +++ b/Makefile 2008-03-05 08:40:50.000000000 -0500
 @@ -0,0 +1,2397 @@
index ae81f84d33969fa6d82c31462956d2314382e49e..59085bf73d2b2c265fc9f79b5c1485b2ca9f1d4d 100644 (file)
@@ -7,8 +7,16 @@ XVKBD_VERSION = 3.2
 XVKBD_SOURCE = xvkbd-$(XVKBD_VERSION).tar.gz
 XVKBD_SITE = http://homepage3.nifty.com/tsato/xvkbd
 
-XVKBD_MAKE_OPT = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" LD="$(TARGET_CC)" \
-                               CFLAGS="-O2 -I$(STAGING_DIR)/usr/include" USRLIBDIR="$(STAGING_DIR)/usr/lib"
+# Passing USRLIBDIR ensures that the stupid Makefile doesn't add
+# /usr/lib to the library search path.
+define XVKBD_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
+               USRLIBDIR="$(STAGING_DIR)/usr/lib"
+endef
+
+define XVKBD_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
 
 XVKBD_DEPENDENCIES = \
        xlib_libICE \
@@ -21,5 +29,5 @@ XVKBD_DEPENDENCIES = \
        xlib_libXt \
        xlib_libXtst
 
-$(eval $(autotools-package))
+$(eval $(generic-package))