Add LTris package (SDL game)
authorJulien Boibessot <julien.boibessot@armadeus.com>
Wed, 8 Jan 2014 13:07:36 +0000 (14:07 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Jan 2014 23:20:34 +0000 (00:20 +0100)
Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/ltris/Config.in [new file with mode: 0644]
package/ltris/ltris.mk [new file with mode: 0644]

index a0fb70446900eb8b57d71b8a119ef28aa9287f11..20e142fdc1f9860d50f87bd94ad5cf0fadd0e36b 100644 (file)
@@ -157,6 +157,7 @@ menu "Games"
 source "package/doom-wad/Config.in"
 source "package/gnuchess/Config.in"
 source "package/lbreakout2/Config.in"
+source "package/ltris/Config.in"
 source "package/prboom/Config.in"
 source "package/rubix/Config.in"
 endmenu
diff --git a/package/ltris/Config.in b/package/ltris/Config.in
new file mode 100644 (file)
index 0000000..1ce52da
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_LTRIS
+       bool "LTris"
+       select BR2_PACKAGE_SDL
+       help
+         LTris as a tetris clone, using SDL. It optionally requires
+         SDL_mixer for audio support.  A display with minimum 640x480
+         resolution and a keyboard are recommanded.
+
+         http://lgames.sourceforge.net/index.php?project=LTris
+
+if BR2_PACKAGE_LTRIS
+
+config BR2_PACKAGE_LTRIS_AUDIO
+       bool "audio support"
+       default y
+       select BR2_PACKAGE_SDL_MIXER
+       help
+         Activates audio support in LTris. Will add SDL_mixer.
+
+endif
diff --git a/package/ltris/ltris.mk b/package/ltris/ltris.mk
new file mode 100644 (file)
index 0000000..e26bf45
--- /dev/null
@@ -0,0 +1,24 @@
+#############################################################
+#
+# ltris
+#
+#############################################################
+
+LTRIS_SITE = http://downloads.sourceforge.net/lgames/ltris/
+LTRIS_VERSION = 1.0.19
+LTRIS_LICENSE = GPLv2+
+LTRIS_LICENSE_FILES = COPYING
+
+LTRIS_DEPENDENCIES = sdl
+
+LTRIS_CONF_ENV = \
+       SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
+
+ifeq ($(BR2_PACKAGE_LTRIS_AUDIO),y)
+LTRIS_DEPENDENCIES += sdl_mixer
+LTRIS_CONF_OPT += --enable-audio=yes
+else
+LTRIS_CONF_OPT += --disable-audio
+endif
+
+$(eval $(autotools-package))