package/siproxd: new package
authorAlexander Dahl <post@lespocky.de>
Wed, 10 Mar 2021 07:38:44 +0000 (08:38 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Mar 2021 17:21:35 +0000 (18:21 +0100)
Siproxd is a masquerading SIP Proxy Server.  We had a buildroot package
for that in the fli4l Linux router distribution for years with different
authors contributing.

Co-authored-by: Christoph Schulz <fli4l@kristov.de>
Co-authored-by: Claas Hilbrecht <babel@fli4l.de>
Signed-off-by: Alexander Dahl <post@lespocky.de>
[yann.morin.1998@free.fr: unconditionally use an external libtool]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/siproxd/Config.in [new file with mode: 0644]
package/siproxd/siproxd.hash [new file with mode: 0644]
package/siproxd/siproxd.mk [new file with mode: 0644]

index 1358971782793422d860e61de3f9a095ff460f02..6eef9f988d1bc49c9382672ee3d36868ade23ba4 100644 (file)
@@ -70,6 +70,7 @@ F:    package/odhcp6c/
 N:     Alexander Dahl <post@lespocky.de>
 F:     package/fastd/
 F:     package/libuecc/
+F:     package/siproxd/
 F:     package/putty/
 
 N:     Alexander Egorenkov <egorenar-dev@posteo.net>
index 1a7d54d12ff563d40080b0a3f07d1d22ad93453f..9a2596e729152d24222a25d8be74d8688b756027 100644 (file)
@@ -1829,6 +1829,7 @@ menu "Networking"
        source "package/resiprocate/Config.in"
        source "package/restclient-cpp/Config.in"
        source "package/rtmpdump/Config.in"
+       source "package/siproxd/Config.in"
        source "package/slirp/Config.in"
        source "package/snmppp/Config.in"
        source "package/sofia-sip/Config.in"
diff --git a/package/siproxd/Config.in b/package/siproxd/Config.in
new file mode 100644 (file)
index 0000000..0a47155
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_SIPROXD
+       bool "siproxd"
+       select BR2_PACKAGE_LIBOSIP2
+       select BR2_PACKAGE_LIBTOOL
+       select BR2_PACKAGE_SQLITE
+       help
+         Siproxd is a proxy/masquerading daemon for SIP (Session
+         Initiation Protocol), which is used in IP telephony. It
+         handles registrations of SIP clients on a private IP network
+         and performs rewriting of the SIP message bodies to make SIP
+         connections work via a masquerading firewall (NAT). It allows
+         SIP software clients (like kphone, linphone) or SIP hardware
+         clients (Voice over IP phones which are SIP-compatible, such
+         as those from Cisco, Grandstream or Snom) to work behind an IP
+         masquerading firewall or NAT router.
+
+         http://siproxd.sourceforge.net/
diff --git a/package/siproxd/siproxd.hash b/package/siproxd/siproxd.hash
new file mode 100644 (file)
index 0000000..be68157
--- /dev/null
@@ -0,0 +1,11 @@
+# Locally calculated after checking pgp signature from:
+# https://downloads.sourceforge.net/project/siproxd/siproxd/0.8.3/siproxd-0.8.3.tar.gz.asc
+sha256  9a6d7a6bb6fff162775b1e1fb7018de9c69642cbf8626185dc6ffceeeba07736  siproxd-0.8.3.tar.gz
+
+# https://sourceforge.net/projects/siproxd/files/siproxd/0.8.3/
+sha1  d13d4a05b8a16dbe20d04b99b535610e49050d9d  siproxd-0.8.3.tar.gz
+md5  9a9d2c89e5f0c59fdde9444a66d8372c  siproxd-0.8.3.tar.gz
+
+# Hash for license files:
+sha256  231f7edcc7352d7734a96eef0b8030f77982678c516876fcb81e25b32d68564c  COPYING
+sha256  f18a0811fa0e220ccbc42f661545e77f0388631e209585ed582a1c693029c6aa  libltdl/COPYING.LIB
diff --git a/package/siproxd/siproxd.mk b/package/siproxd/siproxd.mk
new file mode 100644 (file)
index 0000000..228f085
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# siproxd
+#
+################################################################################
+
+SIPROXD_VERSION = 0.8.3
+SIPROXD_SITE = https://downloads.sourceforge.net/project/siproxd/siproxd/$(SIPROXD_VERSION)
+
+SIPROXD_LICENSE = GPL-2.0+
+SIPROXD_LICENSE_FILES = COPYING
+
+SIPROXD_DEPENDENCIES = libosip2 libtool sqlite
+
+SIPROXD_CONF_OPTS = --without-included-ltdl
+
+$(eval $(autotools-package))