neard: add support for tools
authorSimon Dawson <spdawson@gmail.com>
Fri, 26 Apr 2013 01:25:48 +0000 (01:25 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Apr 2013 14:42:11 +0000 (16:42 +0200)
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/neard/Config.in
package/neard/neard.mk

index bcf61712801d4761827b0743a8072bfd5b5ba0e4..ec1fcb302390d274954a5f82f9ab86cc56d477c5 100644 (file)
@@ -14,5 +14,11 @@ config BR2_PACKAGE_NEARD
 
          https://01.org/linux-nfc/documentation/how-start-linux-nfc-code...
 
+config BR2_PACKAGE_NEARD_TOOLS
+       bool "neard tools"
+       depends on BR2_PACKAGE_NEARD
+       help
+         Build and install neard tools.
+
 comment "neard requires a toolchain with WCHAR and threads support"
        depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index 056875c48eca62933b629e8e22e050a5ac3fefb5..cc6aeacae0ba53c4d4194c19772c39883cafeacd 100644 (file)
@@ -13,4 +13,8 @@ NEARD_AUTORECONF = YES
 NEARD_DEPENDENCIES = host-pkgconf dbus libglib2 libnl
 NEARD_CONF_OPT = --disable-traces
 
+ifeq ($(BR2_PACKAGE_NEARD_TOOLS),y)
+       NEARD_CONF_OPT += --enable-tools
+endif
+
 $(eval $(autotools-package))