package/ola: disable fatal warnings for host variant
authorJörg Krause <joerg.krause@embedded.rocks>
Wed, 21 Sep 2016 23:31:42 +0000 (01:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 22 Sep 2016 18:27:42 +0000 (20:27 +0200)
By default the build system of OLA passes '-Werror' to GCC. The aborts
compilation with GCC 6:

'''
error: ‘template<class> class std::auto_ptr’ is deprecated
[-Werror=deprecated-declarations]
'''

The target variant already passes the option "-disable-fatal-warnings"
to the build system to disable '-Werror'. Do it for the host variant to
to fix build with host GCC 6.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ola/ola.mk

index 6f62a176c264181798eed202a06478cf31498030..75ab25e164c29c2d57f50c92eda66d7fa6ad251f 100644 (file)
@@ -40,7 +40,8 @@ HOST_OLA_CONF_OPTS = \
        --disable-examples \
        --disable-unittests \
        --disable-doxygen-html \
-       --disable-doxygen-doc
+       --disable-doxygen-doc \
+       --disable-fatal-warnings
 
 # On the host side, we only need ola_protoc_plugin, so build and install this
 # only.