infra: add force build flag for host dependencies
authorBryce Ferguson <bryce.ferguson@rockwellcollins.com>
Tue, 27 Nov 2018 04:10:09 +0000 (22:10 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Feb 2019 14:52:44 +0000 (15:52 +0100)
This commit adds a config option which will force buildroot to
build all host dependencies even if they are already present on the
host system. This may be a desirable option if different hosts are
used to build the same source. In this case, some packages will be
built on one host that are not built on another. This is problematic
if build source archives are cached afterwards for offline builds.

Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Bryce Ferguson <bryce.ferguson@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
[Peter: reword, drop exit 1, reshuffle]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
support/dependencies/dependencies.mk

index f965e9d6d8e81142b712e94cd801f821773f37c0..d58d8dc04a81edce6139517c7de544097ba8d443 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -677,6 +677,18 @@ config BR2_COMPILER_PARANOID_UNSAFE_PATH
          and external toolchain backends (through the toolchain
          wrapper).
 
+config BR2_FORCE_HOST_BUILD
+       bool "Force the building of host dependencies"
+       help
+         Build all available host dependencies, even if they are
+         already installed on the system.
+
+         This option can be used to ensure that the download cache of
+         source archives for packages remain consistent between
+         different build hosts.
+
+         This option will increase build time.
+
 config BR2_REPRODUCIBLE
        bool "Make the build reproducible (experimental)"
        # SOURCE_DATE_EPOCH support in toolchain-wrapper requires GCC 4.4
index 563574d6ad92e608fa35a5ae183e3a92b35bc2c2..4fac5c731b2974ce83b1c0e2bcbe6e7792ad6f42 100644 (file)
@@ -5,6 +5,11 @@
 #
 ################################################################################
 
+ifeq ($(BR2_FORCE_HOST_BUILD),y)
+# ignore all available host packages
+define suitable-host-package
+endef
+else
 # suitable-host-pkg: calls check-host-$(1).sh shell script. Parameter (2)
 # can be the candidate to be checked. If not present, the check-host-$(1).sh
 # script should use 'which' to find a candidate. The script should return
@@ -12,6 +17,7 @@
 define suitable-host-package
 $(shell support/dependencies/check-host-$(1).sh $(2))
 endef
+endif
 # host utilities needs host-tar to extract the source code tarballs, so
 # ensure check-host-tar.mk is included before the rest
 include support/dependencies/check-host-tar.mk