package/libssh2: fix zlib library search path issues
authorRomain Naour <romain.naour@openwide.fr>
Sat, 14 Feb 2015 17:38:28 +0000 (18:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 21:01:49 +0000 (22:01 +0100)
Like for lingcrypt and openssl, help the configure script to find
zlib installed in STAGING_DIR.

Otherwise, It might find the one installed on the host:
checking how to link with libz... /usr/lib/libz.so -Wl,-rpath -Wl,/usr/lib

Fixes:
http://autobuild.buildroot.net/results/93b/93b43e114f21a22f0f8b7d7dd6774c089c426cd1

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libssh2/libssh2.mk

index c9f7059bc1ef85e0f47d161d149aa299381ff401..1a1a06f6f240b059fffde30331aa58e5790aca4b 100644 (file)
@@ -31,7 +31,8 @@ endif
 # Add zlib support if enabled
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LIBSSH2_DEPENDENCIES += zlib
-LIBSSH2_CONF_OPTS += --with-libz
+LIBSSH2_CONF_OPTS += --with-libz \
+       --with-libz-prefix=$(STAGING_DIR)/usr
 else
 LIBSSH2_CONF_OPTS += --without-libz
 endif