package/pkg-meson: force-disable binary stripping
authorGleb Mazovetskiy <glex.spb@gmail.com>
Fri, 25 Dec 2020 12:15:59 +0000 (12:15 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 25 Dec 2020 15:57:12 +0000 (16:57 +0100)
In buildroot, stripping for the target is configured and implemented
with the global `BR2_STRIP_strip` option that drive the stripping in
the target-finalize step.

So, we explicitly disable stripping at build time for the target
variants.

For the host variants, however, we don't much care about symbols and
stuff, but smaller executables will hopefully load faster than bigger
ones (disputable, given that sections in ELF files are paged-in
on-demand), so we explictly enable stripping.

Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>
[yann.morin.1998@free.fr:
  - add burb about the target-finalize step
  - enable stripping for host variants
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-meson.mk

index 3a34ba703b2a25534f5a1367d4b41e42eacb90db..e0b843dc3c392ae2077cc69ddcfac63623288a71 100644 (file)
@@ -87,6 +87,7 @@ define $(2)_CONFIGURE_CMDS
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
                --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
                --cross-file=$$($$(PKG)_SRCDIR)/build/cross-compilation.conf \
+               -Dstrip=false \
                -Dbuild.pkg_config_path=$$(HOST_DIR)/lib/pkgconfig \
                $$($$(PKG)_CONF_OPTS) \
                $$($$(PKG)_SRCDIR) $$($$(PKG)_SRCDIR)/build
@@ -105,6 +106,7 @@ define $(2)_CONFIGURE_CMDS
                --localstatedir=$$(HOST_DIR)/var \
                --default-library=shared \
                --buildtype=release \
+               -Dstrip=true \
                $$($$(PKG)_CONF_OPTS) \
                $$($$(PKG)_SRCDIR) $$($$(PKG)_SRCDIR)/build
 endef