package/libplayer: remove mplayer support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 1 May 2018 07:10:14 +0000 (09:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 May 2018 13:40:28 +0000 (15:40 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/libplayer/Config.in
package/libplayer/libplayer.mk

index c51984a3b947ffbb21300ed77f4f3ffce3528d4e..2b03ba732424a3a9c2c5f20b58e7c85e30ac0f84 100644 (file)
@@ -156,6 +156,12 @@ config BR2_PACKAGE_LIBKCAPI_APPS
          Test applications (hasher, rng read, speed-test, test) now
          have their own configuration options in the libkcapi menu.
 
+config BR2_PACKAGE_LIBPLAYER_MPLAYER
+       bool "mplayer support in libplayer removed"
+       select BR2_LEGACY
+       help
+         The mplayer package was removed.
+
 config BR2_PACKAGE_IQVLINUX
        bool "iqvlinux package removed"
        select BR2_LEGACY
index 82083a0eea3d20341a0ceada1ee7ebf32333e481..3cad683248106b0f4c78241d8167533065938586 100644 (file)
@@ -9,11 +9,6 @@ config BR2_PACKAGE_LIBPLAYER
          http://libplayer.geexbox.org/
 
 if BR2_PACKAGE_LIBPLAYER
-config BR2_PACKAGE_LIBPLAYER_MPLAYER
-       bool "mplayer backend"
-       depends on BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS
-       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # mplayer
-       select BR2_PACKAGE_MPLAYER
 
 config BR2_PACKAGE_LIBPLAYER_GSTREAMER
        bool "gstreamer backend"
index f4eccedb06ff626d3e8037b02d9d178e3439a6f2..8d139cea0e55472f60cf25e1319f49aeb548466a 100644 (file)
@@ -20,18 +20,12 @@ define LIBPLAYER_CONFIGURE_CMDS
        ./configure \
                --prefix=/usr \
                --cross-compile \
+               --disable-mplayer \
                $(SHARED_STATIC_LIBS_OPTS) \
                $(LIBPLAYER_CONF_OPTS) \
        )
 endef
 
-ifeq ($(BR2_PACKAGE_LIBPLAYER_MPLAYER),y)
-LIBPLAYER_DEPENDENCIES += mplayer
-LIBPLAYER_CONF_OPTS += --enable-mplayer
-else
-LIBPLAYER_CONF_OPTS += --disable-mplayer
-endif
-
 ifeq ($(BR2_PACKAGE_LIBPLAYER_GSTREAMER),y)
 LIBPLAYER_DEPENDENCIES += gstreamer
 LIBPLAYER_CONF_OPTS += --enable-gstreamer