system: add selection of a default localtime
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 7 Apr 2014 19:58:04 +0000 (21:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Apr 2014 21:56:19 +0000 (23:56 +0200)
[Peter: strip quotes/use local TZDATA_LOCALTIME variable]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[alexandre.belloni: move from "tzdata" to "system configuration"]
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
[yann.morin.1998@free.fr: move into the BR2_TARGET_TZ_INFO conditionnal block]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tzdata/tzdata.mk
system/Config.in

index 59004736e88f171324837a243b9f73c8a8f09d24..c9824dc5cee1ea42f6deccdda38f62c8b4613ada 100644 (file)
@@ -19,6 +19,8 @@ else
 TZDATA_ZONELIST = $(call qstrip,$(BR2_TARGET_TZ_ZONELIST))
 endif
 
+TZDATA_LOCALTIME = $(call qstrip,$(BR2_TARGET_LOCALTIME))
+
 # Don't strip any path components during extraction.
 define TZDATA_EXTRACT_CMDS
        gzip -d -c $(DL_DIR)/$(TZDATA_SOURCE) \
@@ -39,8 +41,13 @@ define TZDATA_INSTALL_TARGET_CMDS
        cp -a $(@D)/_output/* $(TARGET_DIR)/usr/share/zoneinfo
        cd $(TARGET_DIR)/usr/share/zoneinfo;    \
        for zone in posix/*; do                 \
-           ln -sfn "$${zone}" "$${zone##*/}";    \
+           ln -sfn "$${zone}" "$${zone##*/}";  \
        done
+       if [ -n "$(TZDATA_LOCALTIME)" ]; then                           \
+           cd $(TARGET_DIR)/etc;                                       \
+           ln -sf ../usr/share/zoneinfo/$(TZDATA_LOCALTIME) localtime; \
+           echo "$(TZDATA_LOCALTIME)" >timezone;                       \
+       fi
 endef
 
 $(eval $(generic-package))
index d69e880d555748ae5a8db5ebadd351102341de00..c70072994205860c3736424efa6f92d2eb8f6aa5 100644 (file)
@@ -288,6 +288,20 @@ config BR2_TARGET_TZ_ZONELIST
          The full list is the list of files in the time zone database source,
          not including the build and .tab files.
 
+config BR2_TARGET_LOCALTIME
+       string "default local time"
+       help
+         The time zone to install as the default local time, expressed as a
+         tzdata location, such as:
+           GMT
+           Europe/Paris
+           America/New_York
+           Pacific/Wallis
+           ...
+
+         If empty, no local time will be set, and the dates will be
+         expressed in UTC.
+
 endif # BR2_TARGET_TZ_INFO
 
 config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW