ffmpeg: disable mmx for low end x86-type processors
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 28 Feb 2011 14:18:21 +0000 (11:18 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Feb 2011 15:08:55 +0000 (16:08 +0100)
ffmpeg enables mmx by default for x86-class processors, so disable it for
processors that lack it (i386, i486, i586, i686, pentium pro, geode).
Solves bug #3325

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/ffmpeg/ffmpeg.mk

index 60654de06014d113ece776ecbc2843ca106a5bd2..b37ac901e7ee88ada8561db19c78cf8410871e57 100644 (file)
@@ -124,6 +124,11 @@ else
 FFMPEG_CONF_OPT += --disable-zlib
 endif
 
+# MMX on is default for x86, disable it for lowly x86-type processors
+ifeq ($(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_i686)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
+FFMPEG_CONF_OPT += --disable-mmx
+endif
+
 FFMPEG_CONF_OPT += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
 
 # Override FFMPEG_CONFIGURE_CMDS: FFmpeg does not support --target and others