package/poppler: remove qt option
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:50 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:41:12 +0000 (15:41 +0100)
The qt option uses the obsolete qt4 package, which we are about to remove,
so remove the poppler qt option as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Config.in.legacy
package/poppler/Config.in
package/poppler/poppler.mk

index 67e3b0dc7004020d82109027ac0bb36a817f4b35..c1370069483f5262d506d63138882a5d1bf49df6 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2019.02"
 
+config BR2_PACKAGE_POPPLER_QT
+       bool "poppler qt option removed"
+       select BR2_LEGACY
+       help
+         The poppler qt option was removed.
+
 config BR2_PACKAGE_OPENCV3_WITH_QT
        bool "opencv3 qt backend option removed"
        select BR2_LEGACY
index 9b03df8d27587cafcc6c2026e97abf4d92203ac8..4a553df7211b060938b4cce17b841a8af70d0dc6 100644 (file)
@@ -13,14 +13,6 @@ config BR2_PACKAGE_POPPLER
 
 if BR2_PACKAGE_POPPLER
 
-config BR2_PACKAGE_POPPLER_QT
-       bool "Qt support"
-       depends on BR2_PACKAGE_QT
-       select BR2_PACKAGE_QT_GUI_MODULE
-       select BR2_PACKAGE_QT_XML
-       help
-         Build Qt support into the Poppler library
-
 config BR2_PACKAGE_POPPLER_QT5
        bool "Qt5 support"
        depends on BR2_PACKAGE_QT5
index bad61a6613362034510a8895fd9aa1e86186ef78..be1c0e48214d5e9fbcb8b7b04adb63e96c70e9fd 100644 (file)
@@ -12,7 +12,7 @@ POPPLER_LICENSE = GPL-2.0+
 POPPLER_LICENSE_FILES = COPYING
 POPPLER_INSTALL_STAGING = YES
 POPPLER_CONF_OPTS = --with-font-configuration=fontconfig \
-       --enable-xpdf-headers
+       --enable-xpdf-headers --disable-poppler-qt4
 
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 POPPLER_CONF_ENV += LDFLAGS="$(TARGET_LDFLAGS) -latomic"
@@ -84,13 +84,6 @@ else
 POPPLER_CONF_OPTS += --without-x
 endif
 
-ifeq ($(BR2_PACKAGE_POPPLER_QT),y)
-POPPLER_DEPENDENCIES += qt
-POPPLER_CONF_OPTS += --enable-poppler-qt4
-else
-POPPLER_CONF_OPTS += --disable-poppler-qt4
-endif
-
 ifeq ($(BR2_PACKAGE_POPPLER_QT5),y)
 POPPLER_DEPENDENCIES += qt5base
 POPPLER_CONF_OPTS += --enable-poppler-qt5