package/lua-std-debug: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sat, 29 Dec 2018 02:07:23 +0000 (10:07 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 30 Dec 2018 13:48:33 +0000 (14:48 +0100)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas:
 - drop unneeded dependency in Config.in file
 - add entry in DEVELOPERS file
 - fix location of license file
 - add hash for license file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/lua-std-debug/Config.in [new file with mode: 0644]
package/lua-std-debug/lua-std-debug.hash [new file with mode: 0644]
package/lua-std-debug/lua-std-debug.mk [new file with mode: 0644]

index 2d58ea90149420303fd32ffd9abed6dcec440922..e62a445859fe8c29cdb75a87b1f13439eb3065b8 100644 (file)
@@ -1000,6 +1000,7 @@ F:        configs/pine64_defconfig
 F:     configs/pine64_sopine_defconfig
 
 N:     James Hilliard <james.hilliard1@gmail.com>
+F:     package/lua-std-debug/
 F:     package/python-aiodns/
 F:     package/python-aiohttp/
 F:     package/python-aiohttp-jinja2/
index c3e069134ed8aa909745263168c4fb7272ee9094..f33aaf91e98964112b18ffcba9781e8591302006 100644 (file)
@@ -624,6 +624,7 @@ menu "Lua libraries/modules"
        source "package/lua-msgpack-native/Config.in"
        source "package/lua-periphery/Config.in"
        source "package/lua-sdl2/Config.in"
+       source "package/lua-std-debug/Config.in"
        source "package/lua-stdlib/Config.in"
        source "package/lua-testmore/Config.in"
        source "package/lua-utf8/Config.in"
diff --git a/package/lua-std-debug/Config.in b/package/lua-std-debug/Config.in
new file mode 100644 (file)
index 0000000..948f242
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LUA_STD_DEBUG
+       bool "lua-std-debug"
+       help
+         Manage an overall debug state, and associated hint
+         substates.
+
+         http://lua-stdlib.github.io/_debug
diff --git a/package/lua-std-debug/lua-std-debug.hash b/package/lua-std-debug/lua-std-debug.hash
new file mode 100644 (file)
index 0000000..3e94b40
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 7f6b84283d4b78dafee17e7765dd5f1f8e75c3314169977f4dda0e7873616ce2  std._debug-1.0.1-1.src.rock
+sha256 034abdbbe9a13899c813509776d1e04af81bc58c2982b704c8b3663549504a31  _debug-1.0.1/LICENSE.md
diff --git a/package/lua-std-debug/lua-std-debug.mk b/package/lua-std-debug/lua-std-debug.mk
new file mode 100644 (file)
index 0000000..e044d6c
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# lua-std-debug
+#
+################################################################################
+
+LUA_STD_DEBUG_VERSION_UPSTREAM = 1.0.1
+LUA_STD_DEBUG_VERSION = $(LUA_STD_DEBUG_VERSION_UPSTREAM)-1
+LUA_STD_DEBUG_NAME_UPSTREAM = std._debug
+LUA_STD_DEBUG_SUBDIR = _debug-$(LUA_STD_DEBUG_VERSION_UPSTREAM)
+LUA_STD_DEBUG_ROCKSPEC = $(LUA_STD_DEBUG_NAME_UPSTREAM)-$(LUA_STD_DEBUG_VERSION).rockspec
+LUA_STD_DEBUG_SOURCE = $(LUA_STD_DEBUG_NAME_UPSTREAM)-$(LUA_STD_DEBUG_VERSION).src.rock
+LUA_STD_DEBUG_LICENSE = MIT
+LUA_STD_DEBUG_LICENSE_FILES = $(LUA_STD_DEBUG_SUBDIR)/LICENSE.md
+
+$(eval $(luarocks-package))