Teach rsync to compile
authorEric Andersen <andersen@codepoet.org>
Thu, 14 Oct 2004 09:57:31 +0000 (09:57 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 14 Oct 2004 09:57:31 +0000 (09:57 -0000)
package/rsync/rsync.mk
package/rsync/rsync.patch [new file with mode: 0644]

index 10080d038fed363cf59338e66280063dbabba3b4..b66125e9440f44d4be1967a690fc6dd46abab030 100644 (file)
@@ -16,6 +16,7 @@ $(DL_DIR)/$(RSYNC_SOURCE):
 
 $(RSYNC_DIR)/.unpacked: $(DL_DIR)/$(RSYNC_SOURCE)
        $(RSYNC_CAT) $(DL_DIR)/$(RSYNC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(RSYNC_DIR) package/rsync/ rsync*.patch
        touch $(RSYNC_DIR)/.unpacked
 
 $(RSYNC_DIR)/.configured: $(RSYNC_DIR)/.unpacked
diff --git a/package/rsync/rsync.patch b/package/rsync/rsync.patch
new file mode 100644 (file)
index 0000000..9c1927b
--- /dev/null
@@ -0,0 +1,11 @@
+--- rsync-2.6.3/rsync.orig.h   2004-10-14 03:49:54.000000000 -0600
++++ rsync-2.6.3/rsync.h        2004-10-14 03:50:09.000000000 -0600
+@@ -327,7 +327,7 @@
+ #define uint64 unsigned long long
+ #else
+ /* As long as it gets... */
+-#define uint64 unsigned off_t
++#define uint64 loff_t
+ #endif
+ /* Starting from protocol version 26, we always use 64-bit